My Photo

« 背の眼 | Main | WindowsXPの再インストール時の設定メモ »

August 23, 2011

Androidアプリ開発メモ013:minSdkVersion、アプリのアンインストール

最低限必要なAPIレベルの設定
アプリに最低限必要なAPIレベルを設定しておくと、そのAPIレベル以下のシステムにインストールできなくなる。設定しておくべき。
例えばAndroid 2.0での新機能を使ったアプリであれば、AndroidManifest.xmlに以下のように記述しておけば、Android 1.6以下(APIレベル4未満)のシステムにはインストールできなくなる。

<uses-sdk android:minSdkVersion="5" />
バージョンAPI Level
1.53
1.64
2.05
2.0.16
2.17
2.28
2.39
2.3.310


AVDからアプリをアンインストール
AVDを操作して削除する方法の他に、コマンドプロンプトでadbを実行して削除することができる。
adbはtoolsではなくplatform-toolsフォルダにある。

adb uninstall <パッケージ名>
「クラス名」じゃなくて「パッケージ名」なので注意。

« 背の眼 | Main | WindowsXPの再インストール時の設定メモ »

Androidアプリ開発」カテゴリの記事

Comments

Post a comment

(Not displayed with comment.)

TrackBack

TrackBack URL for this entry:
http://app.cocolog-nifty.com/t/trackback/26461/52551346

Listed below are links to weblogs that reference Androidアプリ開発メモ013:minSdkVersion、アプリのアンインストール:

« 背の眼 | Main | WindowsXPの再インストール時の設定メモ »

March 2017
Sun Mon Tue Wed Thu Fri Sat
      1 2 3 4
5 6 7 8 9 10 11
12 13 14 15 16 17 18
19 20 21 22 23 24 25
26 27 28 29 30 31  
無料ブログはココログ

日本blog村

  • にほんブログ村 IT技術ブログへ
  • にほんブログ村 アニメブログへ
  • にほんブログ村 サッカーブログ アルビレックス新潟へ

好きな音楽家

メモ

XI-Prof